Software602 Home . products . download . support . register . how to buy . . view cart . . . contact us . . . .
Software602 Home . . . . . .
. .
.
.
Software602 Login
E-mail:
Password:
forgot?
.
Support Home .
.
User Forum .
.
Knowledge Base .
.
Submit Ticket .
.
View My Tickets .
.
. .
.
602Pro LAN SUITE 2003 User Forumforum home | rss | search | terms of use
BackBack to 602Pro LAN SUITE 2003 Forum
Add New TopicAdd New Topic
Post ReplyPost Reply
Very instable application
  Posted by  Leon Dejong  on Saturday, July 12, 2003 at 4:31:14 AM (EST)
Since my upgrade from LS2002 to LS2003 the app. is very unstable. It shuts down spontaneously a few times a day and sometimes crashes with an Debug Assertion Failure in dgbheap.c. I'm running on W2K SP4.

Furthermore, when running as a service (same problem, service just stops) there's no way of viewing the monitor. I get the message that the application is already running.

Any way to resolve these two situations?

Thanks in advance.

Leon.
  Posted by Robert Smith  on Monday, July 14, 2003 at 10:40:35 AM (EST)
What kind of PC are you running this on? processor speed/amount of installed Ram and OS would be helpful.

How many users are using this? are they using it for surfing as well as mail? do you have a heavy volume of either or both?
  Posted by Leon Dejong  on Monday, July 14, 2003 at 3:54:26 PM (EST)
Ok, you got me there. It's a 933Mhz with 512Mb of memory. There are only 2 users active with little to no mail activity. All is used for browing. There is a (very) heavy load of newsfeed though.
I think I got the pagefile a little too small (180 Mb). I never changed it after upgrading the internal memory. I increased the pagefile now to 1GB and will see if this improves stability.

But that leaves the question about the service. Once installed as a service, how do I run the monitoring function? Now I have to logon first so the application will start. But the monitoring is on all the time. So I want to run the app. as soon as the server boots but also be able to track all the actions.

Thanks.

Léon.
  Posted by Robert Smith  on Monday, July 14, 2003 at 4:11:49 PM (EST)
I think the increase in paging file will help considerably. You have to remember 90% of crashes are because of memory issues. I have a server with 3 GB of memory crammed in it and I've managed to max the memory out (running an accidentally looped SQL query, but that's besides the point)

The only way to insure LS starts at startup would be to run it as a service. If you want to monitor it, you have to run the remote adminstrator or stop the service, and launch the console.

If you had some sort of automatic login capability (like you're using WinXP without logins), then you could probably just run it from the startup group or the command line.
  Posted by Leon Dejong  on Wednesday, July 16, 2003 at 2:45:23 PM (EST)
Alas, it didn't help. Still it just stops. Sometimes when saving the (advanced) settings it gives me error-messages.

A few moments ago the app. shutted down with the message:

Debug Assertion failed.
Program: C:\LANSUITE\Lansuite.exe
File: output.c
Line: 390

Expression: ch!=_T('\0')

For information on how your program can cause an assertion failure, see the Visual C++ documentation on asserts.

Press Retry to debug the application.

Wheellllpp! I'm not a C++ programmer, nor have I the documentation... ;-)

Any suggestions?

System: P933, 10Gb Hd, 512Mb, 2 NIC's, 1Gb Pagefile, Windows 2000 SP4, LS2003 build 2003.0.03.0609
3 User accounts, just using FW, WWW- & Socks proxy, POP3.
  Posted by Leon Dejong  on Wednesday, July 16, 2003 at 2:47:29 PM (EST)
Just to add....:
LS2002 didn't have a problem with SP4 (since I read a lot off different articles saying that SP4 makes everything instable...) It all started after upgrading to LS2003.
BackBack to 602Pro LAN SUITE 2003 Forum
Add New TopicAdd New Topic
Post ReplyPost Reply
.
. . .
.
  © 2009 Software602, Inc. All rights reserved.