Software602 Home . products . download . support . register . how to buy . . view cart . . . contact us . . . .
Software602 Home . . . . . .
. .
Software602 Login
Support Home .
User Forum .
Knowledge Base .
Submit Ticket .
View My Tickets .
. .
602LAN SUITE 2004 User Forumforum home | rss | search | terms of use
BackBack to 602LAN SUITE 2004 Forum
Add New TopicAdd New Topic
Post ReplyPost Reply
Lansuite 2004.0.07.0305 wont work with KB951748
  Posted by  Jesus Marquez  on Thursday, July 10, 2008 at 10:34:51 AM (EST)
I have just installed Windows Security patch KB951748 and
LS has just stop working properly.

When browsing the Internet we get a "Host not found" error.
It happens very often. Sometimes it just works again pressing F5 in IE.

Uninstalling KB951748 just make things work again.

Would there be any patch for LS 2004 to fix this error?

PS: I don't know if this is a LS problem or a Microsoft bad patch.

Best Regards,
Jesus Marquez

Thank you.
  Posted by Robert Smith  on Thursday, July 10, 2008 at 5:14:53 PM (EST)
Zone Alarm issue, maybe?

  Posted by Jesus Marquez  on Friday, July 11, 2008 at 2:25:40 AM (EST)

We are not using Zone Alarm at all.

  Posted by Johan Vanrooyen  on Friday, July 11, 2008 at 11:23:29 AM (EST)
Same problem, problem seems to stem from TCPIP.SYS changes. See MS debug info below. Files implicated psched.sys (MS QOS system file, even with QOS disabled and LS2004 file fwl.sys.

Bugcheck analysis

An attempt was made to access a pageable (or completely invalid) address at an
interrupt request level (IRQL) that is too high. This is usually
caused by drivers using improper addresses.
If kernel debugger is available get stack backtrace.
Arg1: ffffffff, memory referenced
Arg2: 00000002, IRQL
Arg3: 00000000, value 0 = read operation, 1 = write operation
Arg4: adbe3eb9, address which referenced memory

Debugging Details:

READ_ADDRESS: ffffffff


adbe3eb9 833901 cmp dword ptr [ecx],1




PROCESS_NAME: Lansuits.exe

LAST_CONTROL_TRANSFER: from ba558985 to adbe3eb9

a9e9cc24 ba558985 891cc008 886ddef8 00000000 psched!MpSend+0x97
a9e9cc4c bac9a9a6 88cba3e0 886ddef8 88ba8258 NDIS!ndisMSendX+0x1d6
WARNING: Stack unwind information not available. Following frames may be wrong.
a9e9cc70 804ef18f 88cde1c8 886ddef8 806e6410 fwl+0x29a6
a9e9cc80 8057f982 88d16bc8 00000000 88d16b58 nt!IopfCallDriver+0x31
a9e9cc94 8057d4c9 88cde1c8 88d16b58 88ba8258 nt!IopSynchronousServiceTail+0x70
a9e9cd38 8054161c 00000b58 00000000 00000000 nt!NtWriteFile+0x5d7
a9e9cd38 7c90e4f4 00000b58 00000000 00000000 nt!KiFastCallEntry+0xfc
0186d390 00000000 00000000 00000000 00000000 0x7c90e4f4


bac9a9a6 ?? ???


SYMBOL_NAME: fwl+29a6



IMAGE_NAME: fwl.sys


FAILURE_BUCKET_ID: 0xD1_fwl+29a6

BUCKET_ID: 0xD1_fwl+29a6

Followup: MachineOwner
  Posted by Peter Crown  on Sunday, July 13, 2008 at 5:53:26 PM (EST)
Development on 2004 version ended more then year ago. My suggestion is to uninstall Microsoft patch or upgrade 602LAN SUITE to the current version.
  Posted by Robert Smith  on Wednesday, July 23, 2008 at 1:54:36 PM (EST)
Update your LAN drivers.

DRIVER_IRQL_NOT_LESS_OR_EQUAL is a problem with your network card. Check Google on this.
  Posted by Johan Vanrooyen  on Thursday, July 24, 2008 at 3:56:49 AM (EST)
Unfortunately not. Tested all hardware, installed latest drivers(from both Dell and Broadcom)and bios, tried new Intel Nic after disabeling onboard Broadcom unit, tried manipulating timeing properties of NIC, I'm stuck. It's Lansuite2004 related and as development has stoped we know it won't be resolved except if the Microsoft bug report does the trick and they bring out a new update. Although a relatively experienced techy it's probaly above my abilities to resolve. The only solution was to remove the update and exclude it from future updates. Looks like We'll be moving away from the product. Pitty though it's been a wonderfull experience while it lasted. Remember the free version, it still works fine in a different box but with the same onboard NIC.
  Posted by Premysl Pech  on Thursday, July 24, 2008 at 10:02:43 AM (EST)
Well, if you really need a secure firewall you should use a hardware box on the first place. If you used 602LAN SUITE 2004 as mail server, then my suggestion would be try just released Software602 Groupware Server 6.

  Posted by Jesus Marquez  on Monday, July 28, 2008 at 3:58:53 AM (EST)
I'm with Johan Vanrooye.

We were thinking about upgrading to latest version before this issue arised.

But, I think I would have the same problem one year later when a new security patch is released by Microsoft and 602Software states that development on Groupserver 6.0 has ended.

Unfortunately we'll be moving to a different product in a near future.
  Posted by Premysl Pech  on Monday, September 29, 2008 at 12:33:17 PM (EST)
You will not because Groupware Server 6.0 does not include firewall/nat so it is not so sensitive to network layer changes as 2004 version was. Regardless that 6.0 was just released, so it will be supported for next few years in the future. Any OS incompatibilities will be fixed.
BackBack to 602LAN SUITE 2004 Forum
Add New TopicAdd New Topic
Post ReplyPost Reply
. . .
  © 2009 Software602, Inc. All rights reserved.