Software602 Home . products . download . support . register . how to buy . . view cart . . . contact us . . . .
Software602 Home . . . . . .
. .
.
.
Software602 Login
E-mail:
Password:
forgot?
.
Support Home .
.
User Forum .
.
Knowledge Base .
.
Submit Ticket .
.
View My Tickets .
.
. .
.
602LAN SUITE 2004 User Forumforum home | rss | search | terms of use
BackBack to 602LAN SUITE 2004 Forum
Add New TopicAdd New Topic
Post ReplyPost Reply
...has encountered a problem...
  Posted by  Duron Duron  on Saturday, October 28, 2006 at 6:42:38 PM (EST)
Tried the routine outlined by John Lavelle just previous. His approach works, but the first email that comes along brings Lansuite down again.
Tried to submit a ticket (I'd just updated my AV) but no response.
  Posted by John Bull  on Sunday, October 29, 2006 at 6:28:21 AM (EST)
I had exactly this problem, posted a ticket, and support sorted it out for me. Here is their reply:

Quote

We have identified this issue to be an update error with the Anti-virus engine. To correct this issue, do the following:

1. Navigate to your \plugins folder. This folder is located within the 602LAN SUITE folder (usually c:\LANSUITE or c:\Program Files\Software602\602LAN SUITE)
2. Delete the contents of the \plugins folder.
3. Start 602LAN SUITE via the console (Start -> Programs -> 602LAN SUITE 2004 -> 602LAN SUITE).
4. The Anti-virus engine will update to the corrected version and you will be able to process mail again without any problems.

Unquote

Fortunately this worked.

It was a critical problem that made LANsuite unusable.
  Posted by Duron Duron  on Sunday, October 29, 2006 at 7:10:41 AM (EST)
Thanks, but it didn't work. Also tried John Lavelle's approach with no success. System starts up OK but the first email triggers the "602Lan Suite has encountered.." message. I've checked the potentially offending emails and none have been found to have viruses. I'm using Windows One Livecare and Windows defender and are sitting behind a router.
I have had problems before with certain emails locking up 602Lan Suite - once removed, the rest of the emails move on through OK. This one started with the most recent AV update immediately after re-booting so I suspect the problem came with the update.
  Posted by John Bull  on Sunday, October 29, 2006 at 10:31:51 AM (EST)
I'm surprised this didn't work because it seems to be exactly the problem I had.

Beware that you have to get LANsuite back to a clean state with all messages deleted (or moved out) before proceeding. Here is how LANsuite support told be to do this:

Quote

You will need to refer to your log file to locate the message ID of the failing message. [Actually the problem wasn't a failing or corrupt message - it was a problem with the virus scan - but the process is the same]. The 602LAN SUITE log file is located in the root 602LAN SUITE folder (usually c:\LANSUITE or c:\Program Files\Software602\602LAN SUITE by default) and is labeled s[date in mmddyy format]i.log. For example, August 1, 2004's log file would be named s080104i.log.

Open the appropriate file and scroll all the way to the bottom of the log file. You should see a line that appears similar to the following:

Processing message 'nnnnnnnn.x' / 'nnnnnnnn.d'

...where 'nnnnnnnn' is the message ID. This will be located within ten to fifteen lines of your restart point depending on how much traffic is being routed through the server. Using the Windows search tool on your Start menu, search for nnnnnnnn.* (replace the nnnnnnnn string with the correct message ID) to locate and move the files from the \io\internet folder. You may have to do this multiple times to correct this issue, as there may be multiple corrupt messages.

Unquote

I had to go through this process a number of times before I cleared everything out. LANsuite would then run without the "encountered a problem" alert (provided I was careful to avoid any incoming messages). However, without the previous correction the first incoming message would cause the problem all over again. So the process is: 1) clear everything out until LANsuite will run (carefully avoiding any incoming messages), then 2) clear out all the plug-ins, then 3) start up LANsuite from the console.
  Posted by Duron Duron  on Sunday, October 29, 2006 at 2:38:36 PM (EST)
Thanks, but it didn't work. I've emptied all of my mailboxes, removed all of the files from /io/internet, ensured that no incoming messages were possible (set the mail pickup to 2400 hours), then restarted, updated the AV and it ran stable....until I sent one of my accounts an email message from a client and then used the "collect pop3 mailboxes.." to get the mail, the "..problem encountered.." happenned again. I checked the problem file to confirm that it was the one I sent myself. I can confirm that the process is highly repeatable.
So, I've now wiped the PLUGIN file from my system, created a new PLUGIN file, copied all the message folders and everything in /io/internet to another computer then permanently deleted all of the content of the /io/internet/*.pmx files and all of the messages from all message folders, When I send from another network, I get the same "problem encountered.." whether I've updated the AV or not.
My conclusion thus far (after only two days of trying to get our mail server to work) is that when 602Lan Suite puts an incoming message into the /io/internet folder and does whatever with it (with AV installed or not), it triggers the error. It does not appear to do the same with outgoing messages.
  Posted by Robert Smith  on Monday, October 30, 2006 at 5:30:05 PM (EST)
What are the details to the error? I bet it's not the same error if the resolutions didn't work for you. What's the module that's crashing? I'll throw some money on the table that it's not a 602LAN SUITE file What does the log file say? If you don't see a message that looks similar to this:

11:26:35 AM SMTP: : ZapisPrijatouInternetZasilku 0xc0000005

..in the log file, it's not the same error.
  Posted by Duron Duron  on Monday, October 30, 2006 at 5:42:50 PM (EST)
Heres the error message - as noted, it appears to happen as an email gets downloaded from my ISP. Incidentally, have used Ad-Aware, Spybot, Windows Live Onccare and Windows Defender - didn't find anything. System was working well until AV downloaded. I rebooted after download was complete - and it's now three days later. System has been running Lansuite for at least two years with no problems. As to the error messages, I've had no success in deciphering. I hope you're right.

2:37:37 PM POP3: [7] POP3 connection to 'pop51.bellnet.ca' established.
2:37:37 PM SMTP: : GetWordsAndMailsForMailbox 0xeedfade, g_pos=14
2:37:37 PM POP3: [5] Waiting for identification...
2:37:37 PM SMTP: : DoCheckMessageBodyForSpam 0xeedfade, c_pos=1, WordCount=0
2:37:37 PM SMTP: : CheckMessageBodyForSpamAndModifyMessageIfNeeded 0xeedfade, a_pos=22
2:37:37 PM SMTP: : ZapisPrijatouInternetZasilku 0xeedfade, z_pos=39
2:37:37 PM POP3: [8] Waiting for identification...
2:37:37 PM SMTP: : SMTPProcessQueues_Ex 0xeedfade, x_pos=27
2:37:37 PM SMTP: : ThreadSMTPProcessQueues 0xeedfade
  Posted by Duron Duron  on Monday, October 30, 2006 at 6:59:48 PM (EST)
Here's the version of errors after downloading another copy of 602Lan Suite and installing it (second time in three days).
6:44:03 PM SMTP: : GetWordsAndMailsForMailbox 0xeedfade, g_pos=14
6:44:03 PM SMTP: : LearnThisMessageAsSpamOrHam 0xeedfade, l_pos=3, WordCount=0
6:44:03 PM SMTP: : CheckMessageBodyForSpamAndModifyMessageIfNeeded 0xeedfade, a_pos=18
6:44:03 PM SMTP: : ZapisPrijatouInternetZasilku 0xeedfade, z_pos=39
6:44:03 PM SMTP: : SMTPProcessQueues_Ex 0xeedfade, x_pos=27
6:44:03 PM SMTP: : ThreadSMTPProcessQueues 0xeedfade
  Posted by Robert Smith  on Tuesday, October 31, 2006 at 10:23:38 AM (EST)
There's your problem. Your Bayesian database is damaged. Delete the words.db and mails.db file and it should correct the problem.
BackBack to 602LAN SUITE 2004 Forum
Add New TopicAdd New Topic
Post ReplyPost Reply
.
. . .
.
  © 2009 Software602, Inc. All rights reserved.