Software602 Home . products . download . support . register . how to buy . . view cart . . . contact us . . . .
Software602 Home . . . . . .
. .
.
.
Software602 Login
E-mail:
Password:
forgot?
.
Support Home .
.
User Forum .
.
Knowledge Base .
.
Submit Ticket .
.
View My Tickets .
.
. .
.
602LAN SUITE 2004 User Forumforum home | rss | search | terms of use
BackBack to 602LAN SUITE 2004 Forum
Add New TopicAdd New Topic
Post ReplyPost Reply
SMTP Greeting "220 ready"
  Posted by  Ralph G  on Friday, June 16, 2006 at 6:19:30 AM (EST)
(NOTE: I HAVE CHANGED THE REAL DOMAIN NAME TO AVOID BOTS ETC)

Whenever a mailrecipient server performs a reverse DNS (PTR) check on my LanSuite the LanSuite replies with [220 ready] not [220 mailserver.mydomain.co.uk] or alike.

A check with external DNS checking websites state [mailserver.mydomain.co.uk claims to be invalid hostname 'ready':
220 ready]

P.S I have altered the external MX records to list mailserver.mydomain.co.uk and mailserver.mydomain.co.uk has an "A" record.

Any ideas where I can put the correct info into LanSuite. Whatever I type in the domain feild does not show in the reverse DNS (PTR) check EVER and I need a full mailserver.mydomain.co.uk not just mydomain.co.uk

Hope you can help as I am beat!
  Posted by Russell Waddington  on Friday, June 16, 2006 at 3:18:41 PM (EST)
You need to contact the ISP that is providing your IP address. They own the IP address, not you, so only they can set up a reverse entry for that IP.

  Posted by Ralph G  on Saturday, June 17, 2006 at 2:07:22 PM (EST)
Thanks for your reply Russell but as per the line "the LanSuite replies with [220 ready] not [220 mailserver.mydomain.co.uk] or alike." it can be seen that I HAVE got a reverse entry and it is my Lansuite Server itself that is replying to the server doing a reverse query, but my Lansuite server is not replying correctly to the query.
A reply should be three digits and a space or a dash followed by the servername.domain as listed in my external MX records (my external MX records are perfect and so is my A record) so the ISP part has been done.
How can I get the Lansuite server to reply, to anyone querying it from outside, as "220 mailserver.mydomain.co.uk" and not "220 ready" which is not a proper reply and is getting the emails I send listed as spam because the receiving server is doing a reverse check on me and my Lansuite server is saying OH NO I AM NOT CALLED "mailserver.mydomain.co.uk" I AM CALLED "ready" so they don't think I sent the email and think it is spam pretending to be from my mail server.
I wonder if any of the Lansuite programmers read these threads as I can't find any reference to it in the manual either.
  Posted by Ralph G  on Monday, June 19, 2006 at 5:12:37 AM (EST)
Anyone got any ideas?
  Posted by M Blande  on Monday, June 19, 2006 at 1:19:54 PM (EST)
I would be curious why a reverse dns lookup is even going direct to your IP address. The request should be serviced by your ISP's DNS server not the lansuite itself unless you are running a DNS server on the same machine, in which case your machine is missing the reverse dns entry for your IP.
  Posted by Russell Waddington  on Monday, June 19, 2006 at 1:33:20 PM (EST)
Have you got the domain name added to your LS machinge?

Make sure that 'mailserver.mydomain.co.uk' is entered as below.

Right click 'My Computers'
Click on 'Computer Name' tab
Click the 'Change' button.
Make sure the that 'mailserver' is enter in the 'Computer name' box.

click the 'MOre' button
Make sure your domain name (mydomain.co.uk) is enter in the 'Primary DNS ...' box at the top
  Posted by Russell Waddington  on Monday, June 19, 2006 at 3:11:02 PM (EST)
Correction to above reply:

After you select 'My computer'
> Select 'Properties' option <

Then:
Click on 'Computer Name' tab
Click the 'Change' button.
Make sure the that 'mailserver' is enter in the 'Computer name' box.

click the 'MOre' button
Make sure your domain name (mydomain.co.uk) is enter in the 'Primary DNS ...' box at the top
  Posted by Ralph G  on Tuesday, June 20, 2006 at 3:50:23 AM (EST)
Odly enough Russell the computer name and domain name are entered exactly as you mentioned (I had missed the primary DNS though until you pointed it out so thanks) but the server still replys as '220 ready' instead of '220 mailserver.mydomain.co.uk' I have even put "mailserver.mydomain.co.uk" in the HELO/EHLO params of the SMTP form and the domain part "mydomain.co.uk" in the primary domain field of the main form.
I can sit there and watch external servers checking Lansuite in the main Lansuite Log window so I know for sure that the servers are getting to the Lansuite server itself and not being blocked by any firewalls etc but still the little beggar insists on replying as '220 ready'.
By the way, your help is much appreciated.
  Posted by Robert Smith  on Tuesday, June 20, 2006 at 5:32:09 PM (EST)
Make sure you are using the latest build of the software. I vaguely remember an issue with this that was fixed in a previous build.
  Posted by Ralph G  on Tuesday, June 20, 2006 at 6:40:25 PM (EST)
You are so RIGHT!!!

I have Lansuite installed at quite a few clients and was only doing the tests on 3 clients that had been using Lansuite for a few years. I just checked on of the clients that I only installed it at a few months ago and it replys perfectly. I am off to update all the others now. THANK YOU SO VERY MUCH. : )
BackBack to 602LAN SUITE 2004 Forum
Add New TopicAdd New Topic
Post ReplyPost Reply
.
. . .
.
  © 2009 Software602, Inc. All rights reserved.