Software602 Home . products . download . support . register . how to buy . . view cart . . . contact us . . . .
Software602 Home . . . . . .
. .
.
.
Software602 Login
E-mail:
Password:
forgot?
.
Support Home .
.
User Forum .
.
Knowledge Base .
.
Submit Ticket .
.
View My Tickets .
.
. .
.
602LAN SUITE 2004 User Forumforum home | rss | search | terms of use
BackBack to 602LAN SUITE 2004 Forum
Add New TopicAdd New Topic
Post ReplyPost Reply
IIS Web Server Interference?
  Posted by  Andrew Powell  on Wednesday, May 24, 2006 at 9:32:22 AM (EST)
Hello everyone,

Well, I downloaded Lan Suite 2004 based on a number of stellar reviews around, and from what I've seen so far, I'm not disappointed. However, I am having one problem.

I have configured Lan Suite to be my e-mail server and nothing more. No proxys, no NAT, no Firewall, etc. No Web Server.

The PC I installed it on is running my web site using IIS. Even though I have the Lan Suite Web Server disabled, when I try to go to my web site I get a simple (and non-IIS generated) error page that says:

WWW Disabled

I've checked IIS and it's running fine, and I haven't changed anything within my site or IIS. I'm relatively confident that this error is being generated by Lan Suite and I'm hoping someone has a clue about why this is happening and how to fix it.

Thanks in advance for any/all help!

--AP
  Posted by Andrew Powell  on Wednesday, May 24, 2006 at 9:54:25 AM (EST)
Well, even though I'm not using the Lan Suite WWW server, I went into LS's config, changes the LS WWW Server to port 8080 and then saved config, disabled server, and it seems ok.

Web Mail doesn't seem to be working (even though I followed the instructions in the article in the Knowledge Base, but since it's unsupported, I won't go there).

Maybe I'll keep at it and see if I can get it all working together.
  Posted by Andrew Powell  on Wednesday, May 24, 2006 at 11:22:29 AM (EST)
I take it back...even though my web site is back up, now I can't send OR receive e-mail, although I was able to do so prior to switching the HTTP port to 8080.

So, Web site back, but no e-mails, means I'm back at square 1. Maybe I'm not so impressed with this product after all.

Any help?
  Posted by Russell Waddington  on Wednesday, May 24, 2006 at 12:45:25 PM (EST)
Since you are running IIS, make sure you have the SMTP service disabled. IIS installs SMTP by default, and if it starts before LanSuite you will not be able to get messages.

As for the webserver still being active on port 80, the problem might be the proxy. Make sure the proxy is disbled. Also there is an option in the proxy to use a port number other than 80, so that it is separate from you HTTP.

  Posted by Andrew Powell  on Wednesday, May 24, 2006 at 2:59:27 PM (EST)
Hey Russell,

Thanks for the info. First off, do you mean the "Default SMTP Virtual Server" item listed within the IIS MMC? Or do you mean some other SMTP service running within Windows?

I never enabled any proxy server or setting at all. I double checked it, and it is in fact disabled.

I'll go ahead and try to test the mail server after I've disable the Virtual SMTP Server above and hope that does the trick. Thanks.
  Posted by Andrew Powell  on Wednesday, May 24, 2006 at 3:15:31 PM (EST)
Well, I stopped both the Virtual SMTP in IIS as well as the SMTP Windows Service (I'm on XP Pro, by the way), and still can't get the mail server to work now. From the logs, it seems that my client POP3 connections are able to connect and check for mail, but that test messages I send from both my work e-mail account as well as hotmail, neither are arriving at the mail server.

I was running another mail server product previously, and it was working fine (not really, but it was able to send and receive mail), so since I am using all the same standards ports, I know my firewall, NAT and NICs are all fine.

Maybe I should re-install Lan Suite at this point. If I do so, is there any way to NOT install certain pieces of Lan Suite, such as the WWW server and proxy?

Thanks again.

--AP
  Posted by Robert Smith  on Wednesday, May 24, 2006 at 4:57:11 PM (EST)
Reinstalling probably isn't going to fix the problem.

1. Do you see the mail arrive at 602LAN SUITE via the log file?
2. You state you're sending e-mail to your account, I assume you're downloading mail via your ISP's SMTP server?

The log files will show a great deal of information as to what is going on. Collecting e-mail is done via POP3, not SMTP, so it has nothing to do with the SMTP server.
  Posted by Andrew Powell  on Wednesday, May 24, 2006 at 7:57:07 PM (EST)
Ahh...so Lan Suite is not an SMTP server itself?

That must be the problem...my ISP is Comcast (cable) and I'm looking for mail server products, not just things that interface with existing SMTP servers. I guess I ended up here mistakenly. Sorry!

Thanks for the help anyway, it does seem like a nice product.
  Posted by Andrew Powell  on Wednesday, May 24, 2006 at 8:01:53 PM (EST)
Wait a sec...plz disregard my post above. :)

Right. POP3 is the collector. OK.

I can send message from my Outlook client using LS2004 right now. But I don't get any message sent from any other accounts to my account that I've set up within LS.

Now, is Lan Suite it's own POP3 server? Or do I need to have some other one running, and LS will simply periodically connect to that to grab mail?

I think we're on the saem page now, just still not sure if LS is what I'm looking for or not yet. :)

Sorry, it was a long day.
  Posted by Michael Lau  on Thursday, May 25, 2006 at 12:56:22 AM (EST)
I have some ideas for you, pls try.

Check the firewall that is opened port 25 and 110 are allow to any incoming or outgoing actions.

Check the router settings if you are using, here are some points for you becoz different setting with not a same router
1. DMZ / Port Forwarding is forwarded to your PC IP address
2. Virtual Server Setting in router, aim to your PC IP address
3. Using Fix IP address in your network becoz it helps you finding out the problems easily and mail server need a fix IP for receiving e-mail

If you ISP is using DHCP(there means the IP address is not the same when you get connection with ISP), try to use the free dynamic service like no-ip.com or dyndns.org.(DNS-Domain name service)
It is becoz a common sense of local mailling service, the others mail server need to know the address of your mail server before sending mail to you. If your server always change the IP address, it cannot be able to send you any mail.
It will happen the case, you can send to YAHOO!(becoz it always be found in the internet) but YAHOO! cannot send to you(you are the one of the world, it need lots of time to find you. If YAHOO! cannot find you in a period - such as 1 day, it will be forgive to find you again, and return a fail message to yours YAHOO! account)

I hope you can solve the problem asap.
  Posted by Andrew Powell  on Friday, May 26, 2006 at 8:04:27 AM (EST)
Thanks for the advice, but I am 100% sure that it is not a problem with my DMZ, Firewall, port forwarding, etc.

I was using WorkgroupMail server, and I liked it, but the main executable (WMsvc.exe...try it in google) is a known security risk, that I was not willing to take.

But, while I was using it, it was working fine. Mail inbound, mail outbound, all good. It didn't have a lot of the perks this product has, such as web mail and integrated anti-spam, but it got the job done.

Now here I am with this software. I installed it, and as I said, the first thing that happened was my web site become unavailable. I was like, HUH?!

I never had that happen with an e-mail product before, but as I've explained about, simply switching the LS HTTP server to port 8080 fixed that. But now I can't get mail to work!!!

I can send mail outbound with no problems, but I can not currently receive any mail at all. My returned test messages seem to indicate that there is no SMTP service running to accept incoming messages. See below:

--- Session Transcript ---
Thu 2006-05-25 15:46:08: [3414:6] Parsing Message
Thu 2006-05-25 15:46:08: [3414:6] From: ajpowell@chpowell.com Thu 2006-05-25 15:46:08: [3414:6] To: afpjr@rockstorm.com Thu 2006-05-25 15:46:08: [3414:6] Subject: RE: outbound test Thu 2006-05-25 15:46:08: [3414:6] Message-ID: <001601c67f68$f16f3000$6801a8c0@ajpowell>
Thu 2006-05-25 15:46:08: [3414:6] MX-record resolution of [rockstorm.com] in progress (DNS Server: 192.168.1.243)... Thu 2006-05-25 15:46:08: [3414:6] * P=010 D=rockstorm.com TTL=(120) MX=[rockstorm.com] {24.91.51.254} Thu 2006-05-25 15:46:08: [3414:6] Attempting MX: P=010 D=rockstorm.com TTL=(120) MX=[rockstorm.com] {24.91.51.254} Thu 2006-05-25 15:46:08: [3414:6] Attempting SMTP connection to [24.91.51.254 : 25] Thu 2006-05-25 15:46:08: [3414:6] Waiting for socket connection... Thu 2006-05-25 15:46:29: [3414:6] Winsock Error 10060 The connection timed out. Thu 2006-05-25 15:46:29: [3414:6] This message is 1 days old; it has 0 days left to get delivered
--- End Transcript ---

That 24.91.51.254 is the external IP of my network. The same way HTTP requests get forwarded to my internal web server (actually, the same box I am trying to get LS2004 to run on) I have it set to allow POP3 and SMTP traffic to route through. My network is not the problem.

The only thing I have changed since uninstalling WorkgroupMail and installing LS2004 was stopping and disabling the Windows SMTP service as well as the IIS Virtual SMTP server, as Russell indicated I should do. Other than that, I have made no changes to anything, and this software is totally not doing the job I thought it would.

Please note, I never had to stop the native Windows SMTP services with WorkgroupMail, but that may just be part of the different requirements between the two products.

So, I'm still stuck. I was about to reinstall, but was told that wouldn't help. (Why not?!) So this is my last ditch attempt to get any advice about how to get this product to receive mail. That's it.

Thanks for any/all help.

--AP
  Posted by Robert Smith  on Friday, May 26, 2006 at 9:36:54 AM (EST)
Winsock errors are windows errors. :)

connect or send request failed because the connected party did not properly respond after a period of time. (The timeout period is dependent on the communication protocol.)

Check the obvious first: check that the destination address is a valid IP address. If you used a hostname, did it resolve to the correct address? If the hostname resolution uses a local host table, it is possible you resolved to an obsolete address. Can you ping that hostname?

Do you have a router configured? Is the router up and running? (You can check by pinging it, and then ping an address on the other side of it.) Try a traceroute to the destination address to check that all the routers are functioning.

Check your subnet mask. If you don't have the proper subnet mask, your network system may treat a local address as a remote address (so it forwards addresses on the local subnet to the router, rather than broadcasting an ARP request locally), or vice versa.
  Posted by Andrew Powell  on Friday, May 26, 2006 at 2:02:04 PM (EST)
Robert,

Thanks for your good intentions. As I have endeavored to explain, my network is not the problem. As you even point out, it's apparently a windows problem.

The reason I posted the message from the rejected message is so that anyone here can see that yes, the name/IP resolves to my internal address, otherwise you would get 404s for www.rockstorm.com. And you don't.

So, what's the difference between HTTP and e-mail? Ports! But as I have also explained above, I've been using another mail server package and had already configured the proper port forwarding rules on my router and port allowance on my firewall.

MY NETWORK IS NOT THE PROBLEM!!!

Sorry, I'm just getting a bit frustrated. People keep posting about things that are totally not the problem. This has something to do with Windows XP Pro and Lan Suite 2004. That's it. If it's a Windows issue, then I was hoping someone here might have run into a similar situation before and could lend me some advice. If it was a LS2004 issue, I was hoping someone from 602 could help. Apparently neither is the case, and my search for a simple e-mail server continues.
  Posted by Robert Smith  on Tuesday, May 30, 2006 at 3:28:45 PM (EST)
Wow. Just wow. People are trying to help you, no need to blow up at them.

Let's look at the facts:

1. Winsock errors are reported THROUGH LAN Suite from the TCP stack. They are TCP errors, thus Windows errors, as Lan Suite is nothing more than a glorified TCP IP application. This means, in GENERAL terms, it's the exact same as an FTP client, a Web brower, an e-mail client, etc. Only it accepts incoming connections as well.

2. If you are getting a Winsock error, as we established, it indicates exactly what the error is reporting. This is not necessarily a problem with Lan suite, rather a problem with your specific network configuration, firewall settings, etc. The issue is that your mail client cannot connect on the port you specified.

Now, that being said:

- Have you tried changing the port to a different port? Your ISP could be blocking outside access or another service could be running that prevents access on the specified ports (25 and 110). The most notible culprits of this type of problem are anti-virus software. Do you have any anti-virus software installed? If you disable the e-mail scanner, does it work?

- Have you tried accessing it via an internal IP? This will narrow the problem area down to a Internet vs a LAN issue. In other words, if it works from a LAN connection to a LAN IP, then we know the problem is from your router up through your connection.

- What happens when you telnet to the specific port? eg: telnet 123.45.67.89 110 from a command prompt? What happens when you use the internal IP address? This will determine if it's a problem with the client settings or your router/network.

As far as Software602 assisting you, you can buy support from them if you want the problem solved. No company can afford to give away free software and provide the level of support you're asking for.
  Posted by Dzordzs Barens  on Wednesday, July 19, 2006 at 4:16:17 PM (EST)
The LAN SUITE is great software.
I am using it and selling it since 2001.
I am satisfied with it since 2001
I am reseller, since 2001, I love - it is great.

I have used in on Win 98, Win 2000 and Win XP - it works fine.

The problem is in configuration...
BackBack to 602LAN SUITE 2004 Forum
Add New TopicAdd New Topic
Post ReplyPost Reply
.
. . .
.
  © 2009 Software602, Inc. All rights reserved.