Software602 Home . products . download . support . register . how to buy . . view cart . . . contact us . . . .
Software602 Home . . . . . .
. .
.
.
Software602 Login
E-mail:
Password:
forgot?
.
Support Home .
.
User Forum .
.
Knowledge Base .
.
Submit Ticket .
.
View My Tickets .
.
. .
.
602LAN SUITE 2004 User Forumforum home | rss | search | terms of use
BackBack to 602LAN SUITE 2004 Forum
Add New TopicAdd New Topic
Post ReplyPost Reply
100% CPU Utilisation
  Posted by  John Lavelle  on Tuesday, December 20, 2005 at 11:37:25 AM (EST)
I'm running Lan Suite 2004.05.0803 and the old 100% CPU useage is back again. I'm using Windows 2003 Server and *all* the latest service packs and updates.

Note: there is *no* internet or network activity and a check with netstat shows nothing unusual.

I'm running Symantec Corporate Antivirus which is fully up to date and a scan reports no viruses.

Any ideas why Lansuite is running at 100% CPU utilisation? Please


  Posted by John Lavelle  on Tuesday, December 20, 2005 at 11:56:22 AM (EST)
More information about the problem:

I have an ADSL Router (cable modems fixed the last problem according to the posts, but it's back now).

I believe that Lansuite is becoming stuck in a thread when an internet connection is present.

I have deleted all logs, all mail from the mail boxes, switched off everything except the email server and the problem still occurs.

I am not running ZoneAlarm.

Did anyone ever resolve the problem successfully?
  Posted by Torsten RĂ¼ter  on Saturday, December 24, 2005 at 3:35:25 PM (EST)
Hello everyone,

Lansuite 2004, fresh downloaded and installed (2004.0.05.0803)

I've got the same problem. I have just installed a new Lansuite Server after the old one (Windows 2000) is now in pension!
There is no network communication nor other users working on Lansuite. It just hasn't anything to do but the CPU is at 90-100%...

Would be nice to hear from you!
  Posted by David Williams  on Thursday, January 05, 2006 at 3:54:31 AM (EST)
I've found that dynamic IPs can play havoc with it.
Download PROCEXP.EXE from SysInternals (it's a much improved form of Windows Task Manager).

Run it, right click on the LANSUITS.EXE line and select Properties.

Now go to the Threads tab, and click on the column header labelled CPU, to sort the threads by CPU usage.
The little arrow should point down, so the highest CPU use is at the top.

Wait a few seconds, and you should see a thread churning up the CPU, going by the name of WEBPROX.DLL!lber_bprint+0x6b36 (or similar).

Left click on that thread, and then click on the Kill button.

Your CPU usage should now drop back down to normal.

Killing threads like that isn't generally a great idea, but I've done it quite a few times with no ill effects, and the CPU use dropping from 100% to nearly 0% every time.

Hope it helps.

David Williams
  Posted by John Lavelle  on Monday, March 13, 2006 at 5:09:10 PM (EST)
At last I've found the answer to the 100% CPU utilisation.

The Problem is with the LanSuite DNS system NSRESOLV.DLL (specifically the "NSRESOLV.DLL!IsBlackListLineWithIP+0x1a81" Thread - warning DO NOT KILL THIS THREAD).

The fix is:
1. Go into LanSuite Setup
2. Select Proxy
3. Select Proxy Servers
4. Remove the tick (check mark) from "Process DNS requests"
5. Click OK
6. Stop LanSuite (if LanSuite is running as a Service you MUST stop the Service). This is very important as it is this action that stops the DLL running.
7. Restart LanSuite and check your CPU utilisation. It should be back to normal.

Hopefully the people at Software 602 can fix this problem properly now that it has been identified.
  Posted by David Williams  on Tuesday, March 14, 2006 at 6:14:47 AM (EST)
It probably relates to this:

Due to some changes in network stack, Microsoft (r)
windows XP, 2003 and up, may not play well if you
use 127.0.0.1 as the DNS address, in such a case you
may experience excessive CPU usage from the BIND named process; if that's your case, try the following:

* Uninstall BIND, reboot

* Right click on "my computer", select "properties"
then "hardware" and "add new hardware"

* Select the "add new hardware" option

* Select "add new hardware" again from the list

* Select "from a list"

* Select network cards then in the left hand
list select "Microsoft" and in the right one
select "Microsoft Loopback adapter"

* Confirm and proceed to install the virtual
adapter driver

* Open the newly installed adapter properties and
setup its TCP settings using a subnet different
from any other subnet you're using, a good choice
may be using 172.31.254.254/255.255.255.0

* Now proceed installing TreeWalk, once the setup
completes, reboot the machine, then edit your TCP
settings and replace the DNS address from 127.0.0.1
to the address you used for your loopback adapter
(e.g. 172.31.254.254)

* Reboot again and you'll be up and running

Note: an alternative to the above may be applying
this patch listed on the microsoft Knowledge base

http://support.microsoft.com/default.aspx?scid=kb;en-us;884020
BackBack to 602LAN SUITE 2004 Forum
Add New TopicAdd New Topic
Post ReplyPost Reply
.
. . .
.
  © 2009 Software602, Inc. All rights reserved.