Software602 Home . products . download . support . register . how to buy . . view cart . . . contact us . . . .
Software602 Home . . . . . .
. .
.
.
Software602 Login
E-mail:
Password:
forgot?
.
Support Home .
.
User Forum .
.
Knowledge Base .
.
Submit Ticket .
.
View My Tickets .
.
. .
.
602LAN SUITE 2004 User Forumforum home | rss | search | terms of use
BackBack to 602LAN SUITE 2004 Forum
Add New TopicAdd New Topic
Post ReplyPost Reply
WIFI Hotspots and SMTP
  Posted by  Robert Freeborn  on Friday, October 28, 2005 at 5:06:42 PM (EST)
I am having a very similar problem to http://support.software602.com/forum/reply.asp?cid=112&gid=16170&rid=16170
. I have users with PDAs with WIFI built in. When they are out side the local subnet (at an Internet Café for example) they get an undeliverable message error and in the LanSuite logs I see:

12:21:10 PM POP3: [4] 'm610e36d0.someone.net' [xx.xx.xx.xx] connected.
12:21:11 PM POP3: [4] POP3 connection to 'm610e36d0.someone.net' established.
12:21:14 PM POP3: [4] POP3 access to mailbox 'MyBox' started.
12:21:18 PM POP3: [4] POP3 connection to 'm610e36d0.someone.net' properly terminated.
12:21:50 PM SMTP: [4] 'm610e36d0.someone.net' [xx.xx.xx.xx] connected.
12:21:50 PM SMTP: [4] SMTP connection to 'm610e36d0.someone.net' established.
12:21:55 PM SMTP: [4] Rejecting message from MyBox@MyDomain.net for them@otherdomain.com: We do not relay
12:21:55 PM SMTP: [4] (Host doesn't conform to IP Filter settings)
12:21:56 PM SMTP: [4] SMTP connection to 'm610e36d0.someone.net' properly terminated.

I have tried checking/unchecking the box for ‘Relay for 602LAN Suite users only’ and ‘Verify sender by previous POP3 access’. I have not unchecked the ‘IP filter defines access to SMTP relay’ since I have other things like Listserv setup to use this box as it’s SMTP gateway. I don’t know what IP address the portable device will have since they are off site using any number of WIFI hotspots or even cellular connections.

They are able to read new messages via POP3 but not able to send messages via SMTP.

My question is: how do I allow my portable users the ability to send SMTP email with out opening my system up to an ‘open relay’?
  Posted by Robert Freeborn  on Friday, October 28, 2005 at 5:24:10 PM (EST)
Here is one thought I had. It would be nice if 602LAN Suite would temporally add the IP address from the successful POP3 connection to the SMTP Relay IP Filter for a predefined number of minutes. The temporary addition of the IP address should be short enough to not expose your system to ‘open relay’ problems but long enough to send messages with attachments.
  Posted by Donald Chan  on Saturday, October 29, 2005 at 5:28:14 AM (EST)
Just an idea but you may want to check the client (PDA) mail settings as well. For example for Pocket PCs, there is an option in the Messaging program to check the "Outgoing mail requires authentication" box. Or in my case where I use nPOP as my email client, I can either check the "POP before SMTP" or use "SMTP-Auth" to verify my account.
  Posted by Robert Freeborn  on Saturday, October 29, 2005 at 9:18:32 AM (EST)
Donald,

Yes, I have tried the various settings in the PPC client as well. The PPC Inbox could use a little more flexibility where you configure it but I still want to use it instead of installing a 3 rd party application, if possible.

I need to continue testing the other clients as well but the PPC cell phone is the most convenient one to test since I don’t have to setup a test lab or go off site with a laptop.
  Posted by Donald Chan  on Saturday, October 29, 2005 at 3:51:54 PM (EST)
I'd actually try the 3rd Party App to see if it isn't the Messaging Program that's playing up. I've had some trouble with getting the built in PPC Messaging program to connect to Lansuite for the last couple of months. I'm still not sure if it is related to the ROM updates on the PPC or if it was the updates to Lansuite that's giving me the trouble.
  Posted by Donald Chan  on Saturday, October 29, 2005 at 6:36:18 PM (EST)
Hmm...having written my last post I managed to get the default messaging program to work on my PPC by accident (going through a rather convoluted setup procedure). Anyway, I just had a look at my settings and I don't have the SMTP IP Filter checked so that confirms why mine works. (Guess that's not what you wanted to hear). The other thing is maybe to add 0.0.0.0 into the IP mask and IP source fields into the IP filter and permit access. But then again, that's about the same as unchecking the IP filter relay box.

  Posted by Robert Freeborn  on Tuesday, November 01, 2005 at 11:22:43 AM (EST)
Yes, that would kind of defeat the IP filter, wouldn't it? :)

At any rate I'm still looking for a solution to my problem. I thought that the option for ‘Verify sender by previous POP3 access’ would have taken care of this problem but it doesn’t seem to work that way. I sent a message to developers about this but I don’t expect to hear back from them on it. It’s probably too trivial of an issue for them to deal with until the next release of the software.
  Posted by Robert Smith  on Wednesday, November 02, 2005 at 10:12:50 AM (EST)
Your IP filter is the problem.

You will have to either add the IP addresses for the wifi hotspot(s) you frequent or disable the IP filter all together to make this work.

Alternatively, does your PDA have a web browser? You could use the web mail or WAP interface to check/send mail.
  Posted by Robert Freeborn  on Monday, November 07, 2005 at 11:22:07 AM (EST)
Robert,

Sorry, I'm a little frustrated...

If I login via POP3 it should allow me to send SMTP messages if I have that option selected regardless of the IP filter setting. On the other side, if I send an SMTP message from an IP address that is in the IP filter Permit list it should allow me to send an SMTP message regardless of the ‘Verify sender by previous POP3 access’ settings. If I disable the IP filter then the other applications that rely on this machine for SMTP Relay won’t be able to send their messages. The software should allow you select the relay options that meet the needs for the function you want. If they don’t want to make the Relay work this way then they should at least allow you to dynamically add the IP address from the previous POP access to the IP filter allow list for a predetermined amount of time.
  Posted by Richard Mcrae  on Tuesday, November 29, 2005 at 12:20:34 PM (EST)
I'm having this problem too.
BackBack to 602LAN SUITE 2004 Forum
Add New TopicAdd New Topic
Post ReplyPost Reply
.
. . .
.
  © 2009 Software602, Inc. All rights reserved.