Software602 Home . products . download . support . register . how to buy . . view cart . . . contact us . . . .
Software602 Home . . . . . .
. .
.
.
Software602 Login
E-mail:
Password:
forgot?
.
Support Home .
.
User Forum .
.
Knowledge Base .
.
Submit Ticket .
.
View My Tickets .
.
. .
.
602LAN SUITE 2004 User Forumforum home | rss | search | terms of use
BackBack to 602LAN SUITE 2004 Forum
Add New TopicAdd New Topic
Post ReplyPost Reply
LanSuite using 100% of CPU in Server 2003
  Posted by  Michael Moore  on Tuesday, March 16, 2004 at 12:39:57 AM (EST)
lansuits.exe is using 100% of cpu on a freshly installed Server 2003 box, whether installed as a service or run as a GUI application. I've only added 1 user account, and changed the WWW server port. Anyone else having similar issues?
  Posted by Robert Smith  on Tuesday, March 16, 2004 at 10:59:27 AM (EST)
I'm running one of my clients on Windows 2003 and don't have this problem at all. They have about 30 users.

How many users do you have? What does the log file say LAN SUITE is doing when the processor goes to 100%?
  Posted by Michael Moore  on Tuesday, March 16, 2004 at 3:52:08 PM (EST)
I've got a grand total of 1 user (using the free 5 user registration)

I'm a networking & data communications major so I'm setting it up for a learning experience. I messed with the 2002 and 2003 versions a bit, and I don't recall having this type of problem, but it wasn't on Server 2k3.

The log indicates nothing going on. The most that would go on is some checking of remote pop3 accounts, but I experienced the cpu usage issue before configuring that... in fact it appeared to do this from the moment I installed it.

You said you're getting 30% use; I'm curious, what type of hardware do you have? I'm dealing with a Athlon XP 1600+ CPU and 256MB of PC-2700 with over 10GB free on the C: drive (so no virtual memory issues). I do have a ton of services going beacuse it's for a one-user network for educational fun. Other than the base system I configured AD, DNS, DHCP, and WINS. I've not applied any security patches or updates yet.

It seems to me like it's just stuck in a loop or something, but the services LanSuite provides seem to work fine. Email responds quickly from Outlook. The Web admin and webmail works great.. the server just runs at a crawl for everything else.
  Posted by Michael Moore  on Tuesday, March 16, 2004 at 3:54:49 PM (EST)
I think I may have not said it clearly, but the process -stays- at 99% CPU. I've had task manager running for 5 minutes or so and it only goes below 99% when another process (taskmgr) takes some CPU.
  Posted by Russell Waddington  on Tuesday, March 16, 2004 at 6:27:10 PM (EST)
Like you have one computer with lots of services running on it, and just used by me. I have no problems with cpu usage. Like I am running Setiathome, Fluffy the SmtpGuardDog, Lansuit2004, SetiQueue, Sygate, WebWasher, Pestpatrol, DirectUPdate, GriSoft AVG, kiwi Syslog. I have a AMD 1600+, with 1 GIG of memory. Normally SetiatHOme runs around 98%+. But when Fluffy(SMTP preprocessor) gets involved it might take up to 10% of the CPU.

I do not have any problem with LS2004 and CPU usage. By any change are you using the firewall option of LS2004? I am not. Most of the incoming traffic is blocked by the firewall processing on my router. All internal traffic get process by Sygate, and that heardly moves above the 0% line.
  Posted by Michael Moore  on Tuesday, March 16, 2004 at 6:53:23 PM (EST)
Nope, the only LanSuite services I have configured are:

WWW server (For webmail)
POP3 server
POP3 remote collection
SMTP server


  Posted by Robert Smith  on Wednesday, March 17, 2004 at 10:00:14 AM (EST)
My client is running a 2.0ghz P4 w/1GB of RAM.. They are also running SQL server and a propriatary telnet-like server (emulates an AS/400 environment).

You mentioned you had a lot of services running in Win2003, maybe one of them is conflicting with LS or preventing it from writing to the swap file or something like that?
  Posted by Michael Moore  on Wednesday, March 17, 2004 at 4:20:45 PM (EST)
Good thought, but that isn't it.

I disabled all the services I added (MySQL, Apache, DNS, WINS, AV) and no go. I'm thinking the server may have installed weird, because all of a sudden my (MS) DHCP service died and lost its database last night and refuses to re-install and work properly. I smell format and reinstall.

  Posted by Michael Moore  on Wednesday, March 17, 2004 at 5:45:02 PM (EST)
Found why.

It doesn't like Active Directory.

I reformatted and installed the OS. The very next thing was to install LS. Worked fine, no CPU issue. Ran the AD install wizzard (which also installs DNS server, but I ruled that out before since I stopped the DNS service and LS still hogged CPU). Right after the reboot I start LS and it's back to full CPU use again.

So, there you have it. LS 2004 is essentially incompatible (it works but with a high performance cost) with Server 2003 Active Directory.
  Posted by Jason Mcclellan  on Friday, March 19, 2004 at 12:09:18 PM (EST)
Are you absolutely sure about the AD thing? Previous versions have had compatibility/port contention issues with LDAP causing similar problems..
  Posted by Michael Moore  on Friday, March 19, 2004 at 4:25:21 PM (EST)
I'm not using LDAP in LS. It began to act up immediately after AD was installed.
  Posted by Jason Mcclellan  on Friday, March 19, 2004 at 4:55:15 PM (EST)
Just checking.. you don't have to be using it, it just has to be enabled.. if it is, installing AD would cause a problem, since AD includes LDAP of it's own.. this issue is of particular interest to me, because I just upgraded to LS2004, and plan a Server2003 upgrade very soon.. I would be interested to see what tech support says about this
  Posted by Michael Moore  on Friday, March 19, 2004 at 5:00:08 PM (EST)
I just looked, the LDAP address book under Web Admin-Users is not checked.
  Posted by Bernard Mermet  on Saturday, March 20, 2004 at 6:06:10 AM (EST)
Hello.

I have the same problem with 99% cpu consume.

I had LS2003 with AVG and it works very well. I upgrade it with 2004 Antivirus integrated and it word very well. But when i launch the web adminitration tool the the process consumes 99% of CPU and don't decrease !!

Someone finds a solution or has the same problem?

Thank you
  Posted by Jason Mcclellan  on Sunday, March 21, 2004 at 12:26:15 AM (EST)
Well, I purchased and installed the LS2004 upgrade on friday. No real hitches, except it overwrote my customized webmail pages, but that is to be expected because they have made so many additions in there.

One problem though - I have processor utilization issues as well! I am running Windows 2000 Server, which also has AD. I don't have any real problem with proc. time of LS normally, but if I log into webmail, SOMETIMES the lansuite process and the client monitor process will consume 100% cpu time between the two of them. Also, if I do an Activereports run, the activereports process and the lansute process will consume 100% CPU time combined for about 15 minutes, during which time everything is extremely slow - it's not nice about it's cpu usage.

This is a real issue - bogging down the server whenever someone is in webmail is not acceptable! I can understand the activereports being somewhat intensive, but 15 mins of 100% usage on an Athlon 1333 is ridiculous, and the server suffers greatly during this time. And it's not disk usage, it's hard processor utilization.

I don't know if any tech support people read these forums, if they do I would appreciate any insight on this issue. Otherwise, next week I plan to investigate further and document precisely the circumstances of this utilization problem and submit a support request on this issue.
  Posted by Gayland Hopper  on Friday, March 26, 2004 at 9:43:46 AM (EST)
I have been dealing with this problem ever since I upgraded from LS2003. LS2003 worked perfectly with 186 users on an XP box 2gig processor and 256meg ram.
Installed LS2004 over LS2003 worked fine until you access User
Accounts via web... then 100% CPU usage.Left it for 24hrs still 100%. Have to restart LS2004 to get things back to normal.
I contacted support and was pretty well given the run around...like you need more memory or a faster machine. They acted like they never heard of such a thing happening and it must just be my problem. Glad, in a way, someone elese is having problems.
Anyone know if you can install LS2003 over LS2004? I want Ls2003 back.
  Posted by Pcp Dekruyk  on Sunday, March 28, 2004 at 4:31:26 PM (EST)
I have a solution for the problem with 100% cpu....if you have lansuite starts it is a priority problem...if you watch under Task manager (ctr-alt-delete) then you see lansuite.exe is taking a 90% - 100%..thats good, but when you starts a another aplication then is it very slow to start.... if you with the right click on te mouse on lansuite.exe then can you the priority change from normal to low, but if you close the aplication then is it gone the settings....but i have an bat'file written. thats automatically the settings change to priority low if you want that mail to pcp@kruyksba.nl

  Posted by Andrew Etherington  on Thursday, April 01, 2004 at 7:30:17 PM (EST)
I have the same problem - LS2004 takes 100% of the CPU and effectively locks the PC up. In my case though this happens when a client (using Outlook Express) on my LAN tries to download email.

Any ideas what to try? Is technical support working on this?

Andrew.
  Posted by Darrell Lalonde  on Saturday, April 17, 2004 at 1:46:04 AM (EST)
I'm having the same issue will 100% cpu utilization. I do have both LDAP and web admin active so when I get home, I'll have to try turning those off and see what happens. Has there been any more info on this yet?
  Posted by Darrell Lalonde  on Sunday, April 18, 2004 at 12:48:19 AM (EST)
I finally managed to get rid of the 100% cpu usage. I tried other other suggestion put forward so far with no results. I did however turn off Process DNS requirements under Proxy, and cpu utilization dropped to normal. Hope this helps others.

Darrell
  Posted by Gayland Hopper  on Wednesday, July 28, 2004 at 3:26:32 PM (EST)
After installing the latest update to LS2004 my CPU usage at 100% when trying to access user administration via web has been resolved. Thanks to whoever figured the problem out.
  Posted by Christopher Tooker  on Wednesday, November 24, 2004 at 9:56:55 PM (EST)
---- CPU at 100% ---- ARG!!!

Michael is right!! (at least this particular Michael Moore, not the other one - LOL) Ok, I'm sorry, I couldn't resist.

I've been running a 1.3 Duron machine w/ Server2003, and just figured that 2004 liked to suck up all of my CPU. Last night I decided to get onto the newsgroups, and I guess this is why SW602 won't support this. It's "our" fault.
Lansuite has alot of options enabled by default. It is up to the administrator to shut off what is not necessary or will conflict with what is on the machine.
I started with making sure that LDAP was not enabled - still 100%. turned off auto-update and ftp update --- still 100%, made sure that my SMTP was secure, still 100%. Updated to the latest version. still 100%. went on a disabling rampage and discovered - hey - this thing's running DNS. My box is ALREADY running DNS as it's running A/D. I stopped processing DNS requests. Low and behold, I'm at a nice and happy 13%.
Oh yeah, I forgot to mention that I put my old Athlon ghz back in to see if it would be able to handle the requests better since it has more cache.

Bottom line.. keep it simple. If you don't need it, don't use it. and make sure that 602 LS2k4 isn't trying to run the same services that you'ce already enabled in Windows. Hope this helps too!!

Take care and God bless all!! : )

CT
  Posted by Christopher Tooker  on Wednesday, November 24, 2004 at 10:08:12 PM (EST)
One more thing. I also noticed the same issue with logging into webmail, it seems to waste alot of CPU time.
I am not a fan of "application" services.
Guess what? Run the service, and it seems to take up less CPU time when webmail is being accessed.

-- Good night!
  Posted by Torsten RĂ¼ter  on Saturday, December 24, 2005 at 6:17:48 PM (EST)
Good Morning, christmas went well so far?
Well,I've had the same problem witz such an high CPU-Utilization. I've hooked the "Dont dial beacuse of DNS request" and rebooted the machine. Works fine!!!

1700XP, 256MB, 80GB (IDE-RAID 1) '03 Server
BackBack to 602LAN SUITE 2004 Forum
Add New TopicAdd New Topic
Post ReplyPost Reply
.
. . .
.
  © 2009 Software602, Inc. All rights reserved.