Software602 Home . products . download . support . register . how to buy . . view cart . . . contact us . . . .
Software602 Home . . . . . .
. .
.
.
Software602 Login
E-mail:
Password:
forgot?
.
Support Home .
.
User Forum .
.
Knowledge Base .
.
Submit Ticket .
.
View My Tickets .
.
. .
.
602LAN SUITE 2004 User Forumforum home | rss | search | terms of use
BackBack to 602LAN SUITE 2004 Forum
Add New TopicAdd New Topic
Post ReplyPost Reply
Problem enabling SSL
  Posted by  Chuck Partridge  on Thursday, March 11, 2004 at 6:19:56 PM (EST)
I have never gotten the SSL to work correctly. I generated a self-signed certificate, and enabled the WWW SSL port (443).

When I type my url for test (https://127.0.0.1) I get "Client Authentication" dialog from the browser that says "The Web site you want to view request identification. Select certificate to use when connecting." Of course there is no certificate to select.

I have never seen this before. When I hit OK I get the "Cannot find server. Page cannot be displayed" page from IE. The log shows:

4:37:43 PM PROXY: 1632 127.0.0.1 Connection has arrived.
4:37:43 PM PROXY: 1632 Blank URL
4:37:43 PM PROXY: 1632 Connection closed.

and that's it.

This never works. Not from the server PC, or an external PC. I can hit the standard WWW port no problem, but the secure port has never worked.

I have tried running as service and from Start Menu, no difference.

Any ideas? Anyone?
  Posted by Chuck Partridge  on Thursday, March 11, 2004 at 6:24:13 PM (EST)
Sorry, left off the server is running Win 2000 Pro. I have tried with the server over localhost and external PCs. All running Win 2000.

  Posted by Russell Waddington  on Thursday, March 11, 2004 at 8:55:11 PM (EST)
In the administrator console, under the SSL tab, Advanced section: Do you have any of the 'Certificate' chooses selected in the first section. I do not. If you do you might try unselecting them.
  Posted by Chuck Partridge  on Friday, March 12, 2004 at 10:53:01 AM (EST)
What exactly are your settings? I have tried none checked, don't use certificates checked, verify clients checked, and all combinations...

Do I need to restart LS 2004 everytime a change the SSL settings, or are they effective immediately?

Thanks,

Chuck
  Posted by Chuck Partridge  on Friday, March 12, 2004 at 3:53:40 PM (EST)
After I restarted my service with all the "certificate" boxes clear, my Secure Web Server started to work. My POP3 and SMTP work also. I have found that not all email systems like self-certified certificates. My work uses Novell Groupwise and it doesn't like to talk POP3 over SSL, it never completes the SSL handshakes. Oh well...I guess I can pay for a certificate if I need it that bad.

Thanks for the help!
BackBack to 602LAN SUITE 2004 Forum
Add New TopicAdd New Topic
Post ReplyPost Reply
.
. . .
.
  © 2009 Software602, Inc. All rights reserved.