Software602 Home . products . download . support . register . how to buy . . view cart . . . contact us . . . .
Software602 Home . . . . . .
. .
.
.
Software602 Login
E-mail:
Password:
forgot?
.
Support Home .
.
User Forum .
.
Knowledge Base .
.
Submit Ticket .
.
View My Tickets .
.
. .
.
602Pro LAN SUITE 2003 User Forumforum home | rss | search | terms of use
BackBack to 602Pro LAN SUITE 2003 Forum
Add New TopicAdd New Topic
Post ReplyPost Reply
Unable to offer port 80 HTTP services
  Posted by  Jon-david Kresovich  on Wednesday, February 18, 2004 at 12:52:19 PM (EST)
I don't seem to be able to offer HTTP services (on port 80) outside my local area network.

I run WinXP Pro with Internet connection sharing (ICS); I don't use the Internet connection firewall (ICF). I run Trend PC-Cillin and have disabled that built-in firewall as well. The situation presents itself whether or not the LAN SUITE firewall is running. (But, when it is running, port 80 is configured for unrestricted access to/from.)

Remotely, I cannot reach the Web server; locally, I can get to everything--even by way of the WAN IP address.

GRC.com's port analysis reports port 80 as "stealth", i.e., no evidence that any service is running on the port.

The situation affects LAN SUITE and Apache equally. (At any time I run only one of the Web servers--there are no port 80 conflicts.)

Any ideas? I'd like to stick with Apache. I've experimented with varous "Listen" directives to guarantee access to appropriate network adapters, but still no luck.

Thank you very much!
  Posted by Jon-david Kresovich  on Wednesday, February 18, 2004 at 1:02:50 PM (EST)
Just a quick follow-up; I omitted what might be an important piece of information:

I do not run LAN SUITE proxies; I do not run proxies of any sort.

Thanks again!
  Posted by Russell Waddington  on Wednesday, February 18, 2004 at 5:41:18 PM (EST)
What you have not stated is weather you are using a router, with your internet connection attached to it. These can have built in firewalls which you may have to open.
  Posted by Jon-david Kresovich  on Wednesday, February 18, 2004 at 5:54:45 PM (EST)
Apologies for the omission; the WinXP Pro box is connected directly to the Internet. There is no router involved.

Thanks.
  Posted by Andy Sharrem  on Thursday, February 19, 2004 at 3:27:03 PM (EST)
You need to enable the Web Service Port in ICS. ICS is a NApT, and the Firewall is independant of this.
  Posted by Jon-david Kresovich  on Thursday, February 19, 2004 at 5:50:52 PM (EST)
I've tried altering the properties you suggest... to no avail. Today I uncovered an article on Geek.com:

Cox to block cable e-mail and Web servers

--------------------------------------------------------------------------------
posted 12:57pm EST Fri Jun 13 2003 - submitted by Christopher R. Anderson
NEWS
Cox Communications has announced that it will begin blocking inbound traffic on ports 25 and 80 for cable modems, effective July 14, 2003. By not allowing traffic on those ports the company is effectively shutting down cable customers' Web servers and e-mail servers...

Alright, then, there you have it; that's my problem. I'd already worked around the SMTP issues, but hadn't thought port 80 would be blocked! Time to work around that, too.

Cheers and thanks to everyone who took the time to comment.
BackBack to 602Pro LAN SUITE 2003 Forum
Add New TopicAdd New Topic
Post ReplyPost Reply
.
. . .
.
  © 2009 Software602, Inc. All rights reserved.