Software602 Home . products . download . support . register . how to buy . . view cart . . . contact us . . . .
Software602 Home . . . . . .
. .
.
.
Software602 Login
E-mail:
Password:
forgot?
.
Support Home .
.
User Forum .
.
Knowledge Base .
.
Submit Ticket .
.
View My Tickets .
.
. .
.
602Pro LAN SUITE 2003 User Forumforum home | rss | search | terms of use
BackBack to 602Pro LAN SUITE 2003 Forum
Add New TopicAdd New Topic
Post ReplyPost Reply
Stand Alone SMTP Server
  Posted by  R.t. Brown  on Thursday, January 15, 2004 at 2:58:21 PM (EST)
Hi,

Trying to setup a simple (outgoing) smtp server. I don't need to use LS to receive mail, I'll continue to do this thru my email client, I'd simply like to send using localhost.

Here's what I've done thus far:

1.) Relaying is not a prob...I've setup aliases.
2.) DNS entries are setup

Should be fairly simple...I don't receive any errors when trying to send...the mail just never arrives.

Here are some entries to the logfile:

2:24:52 PM SMTP: [1] 'localhost' [127.0.0.1] connected.
2:24:52 PM SMTP: [1] SMTP connection to 'localhost' established.
2:24:53 PM SMTP: [1] Receiving message to 'C:\LANSUITE\io\internet\302ea628.d'.
2:24:53 PM SMTP: [1] Message received (778 B).
2:24:53 PM SMTP: [1] SMTP connection to 'localhost' properly terminated.
2:25:34 PM SMTP: Processing message '302ea628.x'/'302ea628.d'
2:25:34 PM SMTP: Message delivered to 1 local users.
2:25:34 PM SMTP: Total processed 1 RFC-822 messages
2:29:23 PM SMTP: [1] 'DESKTOP' [192.168.2.40] connected.
2:29:23 PM SMTP: [1] SMTP connection to 'DESKTOP' established.
2:29:23 PM SMTP: [1] Receiving message to 'C:\LANSUITE\io\internet\302ea62a.d'.
2:29:23 PM SMTP: [1] Message received (791 B).
2:29:23 PM SMTP: [1] SMTP connection to 'DESKTOP' properly terminated.
2:29:34 PM SMTP: Processing message '302ea62a.x'/'302ea62a.d'
2:29:34 PM SMTP: Message delivered to 1 local users.
2:29:34 PM SMTP: Total processed 1 RFC-822 messages
2:30:12 PM SMTP: [1] 'DESKTOP' [192.168.2.40] connected.
2:30:12 PM SMTP: [1] SMTP connection to 'DESKTOP' established.
2:30:13 PM SMTP: [1] Receiving message to 'C:\LANSUITE\io\internet\302ea62c.d'.
2:30:13 PM SMTP: [1] Message received (787 B).
2:30:13 PM SMTP: [1] SMTP connection to 'DESKTOP' properly terminated.
2:30:34 PM SMTP: Processing message '302ea62c.x'/'302ea62c.d'
2:30:34 PM SMTP: Message delivered to 1 local users.
2:30:34 PM SMTP: Total processed 1 RFC-822 messages
2:30:38 PM Configuration saved.
2:30:57 PM SMTP: [1] 'DESKTOP' [192.168.2.40] connected.
2:30:57 PM SMTP: [1] SMTP connection to 'DESKTOP' established.
2:30:58 PM SMTP: [1] Receiving message to 'C:\LANSUITE\io\internet\302ea62e.d'.
2:30:58 PM SMTP: [1] Message received (771 B).
2:30:58 PM SMTP: [1] SMTP connection to 'DESKTOP' properly terminated.
2:31:35 PM SMTP: Processing message '302ea62e.x'/'302ea62e.d'
2:31:35 PM SMTP: Message delivered to 1 local users.
2:31:35 PM SMTP: Total processed 1 RFC-822 messages
2:32:41 PM Configuration saved.

Thanks for any suggestions!
  Posted by Russell Waddington  on Thursday, January 15, 2004 at 5:33:50 PM (EST)
Looking at log segment, it appears that all mail is local and no internet sending is taking place. In other words, you are going from one LS mailbox, to another LS mailbox. Is this what you intented? Just asking since you said you set up aliases. If you set up an external email address to be an alias to a LS mailbox, it will be treated as a local address. So it will get routed to the LS mail address and not the external address.
  Posted by R.t. Brown  on Thursday, January 15, 2004 at 5:42:43 PM (EST)
Yes, that seems to be exactly what's happening. I setup another email client to receive pop mail from the local host and that's where everything is going. In that case, I'm a little confused...

I guess I don't want the aliases? But if I don't have them, I get mail relay errors...I know I'm missing something! Any suggestions are appreciated!

Thanks!

RT
  Posted by Russell Waddington  on Thursday, January 15, 2004 at 8:56:03 PM (EST)
To send email you need the check box 'allow lansuite users only to send mail' checked. That is default. And then the 'from' address needs to be defined to LS2003.

Since you getting the PoP3 from your isp, and sending from LS2003, you need your ISP's email name setup in LS. So yes you need the aliases.

It is if you try to send email to an alias address, it will stay local. If you define a hotmail account, and then send email from one of your aliased addresses, that should work.

What you could try doing is setting up SMTP IP filters. You will need 2 filters. One for IP address '127.0.0.1' mask '255.255.255.255'. The other for '192.168.0.0', mask '255.255.0.0'. You will find a check box 'use IP filters' on the same page as 'allow Lansuite users to rely'. and then go to the 'smtp filter tab' and enter the above numbers. Now you might be able to get rid to the aliases.
  Posted by R.t. Brown  on Thursday, January 15, 2004 at 9:51:00 PM (EST)
It's strange...I've deselected the "only LS Users" option, and I'm not using any IP filter and that is what seems to make it work. I'm wondering if that would open the SMTP server to spammers?

It is behind a firewall using NAT, etc...
BackBack to 602Pro LAN SUITE 2003 Forum
Add New TopicAdd New Topic
Post ReplyPost Reply
.
. . .
.
  © 2009 Software602, Inc. All rights reserved.